CCCUK logo

 Lancaster Insurance

Website Control

Recent threads

New Forum Posts

» Radiator options? by Nosheruk on Sat 02 Feb 19 20:38

» Corvette C6 Coupe Wanted by Carl on Fri 01 Feb 19 14:38

» New Website and Forum by roscobbc on Fri 01 Feb 19 13:13

» Donington Historic May 3/4/5 by JonnyC4 on Fri 01 Feb 19 05:50

» CCCUK Website and Forum by Rich on Wed 30 Jan 19 21:55

» C6 Z06 Flat battery by Tattooboy on Wed 30 Jan 19 13:35

» WANTED C5 third brake light unit by roppa440 on Wed 30 Jan 19 12:16

» South Central Midlands Breakfast Meet by Daytona Vette on Wed 30 Jan 19 11:08

» V55 question for imported C2 by kentvette on Wed 30 Jan 19 09:16

» Transport & tyre recommendations by Johnd on Tue 29 Jan 19 15:38

» Turn signal lever cars with cruise by phill78 on Tue 29 Jan 19 13:12

» New Series of Wheeler Dealers an 02 Z06?? by 5 USA on Mon 28 Jan 19 20:21

» Hilarious quote of the weekend..... by roscobbc on Mon 28 Jan 19 18:10

» yellow metalflake vinyl steering wheel by Daytona Vette on Mon 28 Jan 19 17:29

» 74 c3 for sale by MIT on Mon 28 Jan 19 06:44

» Cooling system pressure tester kits by rayquayle on Sun 27 Jan 19 13:18

» Paid up member by Nosheruk on Sun 27 Jan 19 08:52

» Drifting your Corvette by Mule on Sat 26 Jan 19 13:09

» Newbie with a 76 by DAN@ADRIAN FLUX on Sat 26 Jan 19 11:40

» Spotted some well-hidden Z06 (C5) wheels for sale on flea-bay by VetteWeekend on Fri 25 Jan 19 13:34

» What did you do with your Vette today? by Forrest Gump on Tue 22 Jan 19 23:20

» New Unexpected Owner of this C3!! by alexm on Tue 22 Jan 19 21:46

» Power Windows by Jimbo64 on Tue 22 Jan 19 17:40

» radio suppressor ??? by 5 USA on Tue 22 Jan 19 12:50

» Any interest in used Z06 suspension? by Sub8 on Tue 22 Jan 19 11:18

» Rear wheel bearing by Clive on Tue 22 Jan 19 08:11

» Help with newly acquired 72 350 Auto by Jimbo64 on Mon 21 Jan 19 18:31

» This seems very cheap for a C7 by roscobbc on Mon 21 Jan 19 17:28

» Indicator/hazards switch by vet80y on Mon 21 Jan 19 06:36

» Front end parts for a 1973 C3 Small Block Auto by Lomaximus on Sat 19 Jan 19 15:28

indicator problem



Reply to topic
View previous topicEmail to a FriendPrinter FriendlyView next topic

Author

Message

damc3

Club Member

Sat 12 May 18 09:48

indicator problem


my 77 c3"s indicator wiring seems to have been hacked about with Banghead its got a brand new switch fitted by me and a new flasher unit but the direction lights on the dash just light up but don't flash ! which is what the lamps do as well ..the hazards work fine as I know they are on a different circuit but the large parking lights at the front have had the lenses painted with amber paint /laquer .. and the bulb holders which fit into these lenses have got 3 wires ..2 live and an earth with a twin filament bulb ..one wire has been disconnected so the bulb will work as the indicator in the lamp ( hope im not making it complicated !!) so im wondering if the wire that's been disconnected needs to be re connected to make a circuit ? any help would be great as im pulling my hair out here and ive not got much left !! lol oh and its also got some after market lamps fitted into the grille which come on for the sidelights but aren't very bright ..I can post pictures later if it helps .cheers Thumbs up dave ...ps if anyones local to me in Manchester I will gladly pay to have someone look at it my postcode is m329ga Thumbs up

Reply with quote

Grahamred70

Club Member

Sat 12 May 18 12:34


If the 77 side lights are the same as my 70, I had clear lenses with twin filament amber bulbs, 5W for side and 15W for indicator, all I did was fit switchback led bulbs which show white for the sidelight and amber for the indicator, when indicating with the lights on the white and amber alternate. You'll need to carefully remove the amber coating from your lenses for them to work correctly, hope this helps.
Graham


--------------------
Graham, red 1970 convertible 350

Reply with quote

kentvette

Club Member

Sat 12 May 18 12:55

Re: indicator problem


I think that by '77 the lights were same as on my 78, and similar to Graham's. The original lamp unit had a dual filament bulb, white lenses and white bulbs. I added a lamp in the grill for indicators, so moved the power feed from the original unit and added an earth.

I doubt that having the arrangement you have would stop the flashing. My thoughts as a non expert on electrics would be flasher unit related. The original unit is a bi-metal unit, not electric. You'd need the correct flasher unit to make them flash. I understand that you can convert to an electric unit, with additional wiring?

Similarly, with the original flasher unit, LED bulbs sometimes make it flash too fast, as they do not have the same resistance.

Out of interest, are the front side markers still wired into the indicator circuit on yours? I had to remove mine, as they flashed alternately to the front units (illegal in the UK), but have since re-wired them as additional indicators, and taken them out of the side light circuit.


--------------------
Stephen J Irons
CCCUK Lifetime Member
Corvette Club France
Corvettes of Southern California
NCM Family Member
Stephen & June's Web Site
Red Corvettes Have More Fun!

Apple IS Genisys!
The "Born-Again Greenies" are killing the planet! It's time to wake up and smell the rain-forest burning!

Reply with quote

damc3

Club Member

Sat 12 May 18 14:42

Re: indicator problem


woo hoo its sorted Willy I tried a different flasher unit and It seems to have done the trick ..thanks for your help guys much appreciated Smile heres the unit I fitted Thumbs up


Attachment:

imagesZ326TIGR.jpg

Reply with quote

kentvette

Club Member

Sun 13 May 18 16:38

Re: indicator problem


Nice one!

Where did you get that fancy transparent flasher unit? Hope you fitted it somewhere you can see it working! Very Happy Very Happy


--------------------
Stephen J Irons
CCCUK Lifetime Member
Corvette Club France
Corvettes of Southern California
NCM Family Member
Stephen & June's Web Site
Red Corvettes Have More Fun!

Apple IS Genisys!
The "Born-Again Greenies" are killing the planet! It's time to wake up and smell the rain-forest burning!

Reply with quote

damc3

Club Member

Sun 13 May 18 21:11

Re: indicator problem


good ol ebay Thumbs up and I didn't think to watch it working !! that's a job for tomorrow Laughing

Reply with quote

Reply to topic
View previous topicEmail to a FriendPrinter FriendlyPrivate MessengerView next topic


Permissions

You cannot post new threads in this forum
You cannot reply to threads in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot add events in this forum
You cannot attach files in this forum
You can download files in this forum